Java String Tokens - Hacker Rank Solution
Hello Friends, How are you? Today I am going to solve the HackerRank Java String Tokens Problem with a very easy explanation. This is the 19th problem of Java on HackerRank. In this article, you will get more than one approach to solving this problem. So let's start-
{tocify} $title={Table of Contents}
HackerRank Java String Tokens - Problem Statement
Given a string, s, matching the regular expression [A-Za-z !,?._'@]+, split the string into tokens. We define a token to be one or more consecutive English alphabetic letters. Then, print the number of tokens, followed by each token on a new line.
Note: You may find the String.split method helpful in completing this challenge.
Input Format
A single string, s.
Constraints
- 1 <= length of s <= 4 * 10^5
- s is composed of any of the following: English alphabetic letters, blank spaces, exclamation points (!), commas (,), question marks (?), periods (.), underscores (_), apostrophes ('), and at symbols (@).
Output Format
On the first line, print an integer, n, denoting the number of tokens in string s (they do not need to be unique). Next, print each of the n tokens on a new line in the same order as they appear in input string s.
Sample Input
He is a very very good boy, isn't he? {codeBox}
Sample Output
10 He is a very very good boy isn t he {codeBox}
Explanation
We consider a token to be a contiguous segment of alphabetic characters. There are a total of 10 such tokens in string s, and each token is printed in the same order in which it appears in string s.
Java String Tokens - Hacker Rank Solution
Approach I:
import java.util.Scanner;
public class Solution {
public static void main(String[] args) {
/* Read input */
Scanner scan = new Scanner(System.in);
String s = scan.nextLine();
scan.close();
s = s.trim(); // so that .split() works properly
/* Check special cases */
if (s.length() == 0) {
System.out.println(0);
return;
}
/* Split on all non-alphabetic characters */
String [] words = s.split("[^a-zA-Z]+");
/* Print output */
System.out.println(words.length);
for (String word : words) {
System.out.println(word);
}
}
}
import java.io.*;
import java.util.*;
public class Solution {
public static void main(String[] args) {
Scanner scan = new Scanner(System.in);
String s = scan.nextLine();
scan.close();
s = removeLeadingNonLetters(s);
/* Check special cases */
if (s.length() == 0) {
System.out.println(0);
return;
}
/* Split on all non-alphabetic characters */
String[] words = s.split("[^a-zA-Z]+");
/* Print output */
System.out.println(words.length);
for (String word : words) {
System.out.println(word);
}
}
private static String removeLeadingNonLetters(String str) {
int i;
for (i = 0; i < str.length(); i++) {
if (Character.isLetter(str.charAt(i))) {
break;
}
}
return str.substring(i);
}
}
import java.io.*;
import java.util.*;
import java.util.stream.Collectors;
public class Solution {
public static void main(String[] args) {
Scanner scan = new Scanner(System.in);
String s = scan.nextLine();
scan.close();
String splits[] = s.split("[!,?._'@ ]");
splits = Arrays.asList(splits).stream().filter(str -> !str.isEmpty()).collect(Collectors.toList()).toArray(new String[0]);
System.out.println(splits.length);
for(String z : splits)
System.out.println(z);
}
}
Also Check:
Disclaimer: The above Problem ( Java String Tokens ) is generated by Hackerrank but the Solution is Provided by MyEduWaves. This tutorial is only for Educational and Learning purposes. Authority if any of the queries regarding this post or website fill the contact form.
I hope you have understood the solution to this HackerRank Problem. All these three solutions will pass all the test cases. Now visit Java String Tokens HackerRank Problem and try to solve it again.
All the Best!
Tags:
HackerRank Java